HACKING

Elementor WordPress plugin: Κρίσιμη ευπάθεια επηρεάζει χιλιάδες sites

This post was originally published on this site

Οι δημιουργοί του Elementor Website Builder plugin για WordPress κυκλοφόρησαν την έκδοση 3.6.3 για να διορθώσουν μια κρίσιμη ευπάθεια που επιτρέπει σε κακόβουλους χρήστες να εκτελέσουν κώδικα απομακρυσμένα. Η ευπάθεια μπορεί να επηρεάσει έως και 500.000 sites.

Για να γίνει επιτυχημένη εκμετάλλευση του σφάλματος του WordPress plugin απαιτείται έλεγχος ταυτότητας. Ωστόσο, το σφάλμα θεωρείται κρίσιμο επειδή οποιοσδήποτε είναι συνδεδεμένος στον ευάλωτο ιστότοπο μπορεί να το εκμεταλλευτεί, ακόμα και οι απλοί subscribers.

Δείτε επίσης: Πάτρα: Κεντρική φαρμακαποθήκη δέχτηκε κυβερνοεπίθεση

Elementor WordPress plugin ευπάθεια

Ένας επιτιθέμενος θα μπορούσε να δημιουργήσει έναν κανονικό λογαριασμό χρήστη σε έναν επηρεαζόμενο ιστότοπο και να αλλάξει το όνομα και το θέμα του ιστότοπου, κάνοντάς τον να φαίνεται εντελώς διαφορετικός.

Ερευνητές ασφαλείας έχουν προτείνει ότι και ένας μη συνδεδεμένος χρήστης θα μπορούσε να εκμεταλλευτεί την κρίσιμη ευπάθεια που διορθώθηκε πρόσφατα στο Elementor Website Builder plugin για WordPress, αλλά αυτό το σενάριο δεν έχει επιβεβαιωθεί.

WordPress: Ευπάθεια στο Elementor Website Builder plugin

Ερευνητές της υπηρεσίας ασφαλείας του WordPress, Plugin Vulnerabilities, βρήκαν την ευπάθεια και περιέγραψαν σε μια έκθεση τις τεχνικές λεπτομέρειες πίσω από αυτό το ζήτημα στο Elementor.

Δείτε επίσης: Ανίδεοι χάκερ πέρασαν μήνες μέσα σε ένα δίκτυο γιατί δεν ήξεραν τι να κάνουν

Σύμφωνα με την έκθεση, το πρόβλημα έγκειται στην απουσία κρίσιμου ελέγχου πρόσβασης σε ένα από τα αρχεία του plugin, το “module.php”, το οποίο φορτώνεται σε κάθε request κατά τη διάρκεια της ενέργειας admin_init, ακόμη και για χρήστες που δεν είναι συνδεδεμένοι.

Ένα από τα functions που ενεργοποιούνται από το admin_init action επιτρέπει τη μεταφόρτωση αρχείων με τη μορφή ενός WordPress plugin. Ένας επιτιθέμενος θα μπορούσε να τοποθετήσει ένα κακόβουλο αρχείο εκεί για να επιτύχει εκτέλεση κώδικα απομακρυσμένα.

Περισσότερες λεπτομέρειες για την ευπάθεια, μπορείτε να δείτε στην έκθεση της Plugin Vulnerabilities.

Διόρθωση ευπάθειας

Σύμφωνα με τους ερευνητές της Plugin Vulnerabilities, το ζήτημα παρουσιάστηκε με το Elementor 3.6.0, το οποίο κυκλοφόρησε στις 22 Μαρτίου 2022. Τα στατιστικά του WordPress αναφέρουν ότι περίπου το 30,7% των χρηστών του Elementor έχουν κάνει αναβάθμιση στην έκδοση 3.6.x, κάτι που δείχνει ότι ο μέγιστος αριθμός sites που ενδέχεται να επηρεαστούν είναι περίπου 1.500.000.

Χθες έγινε λήψη του plugin πάνω από ένα εκατομμύριο φορές. Αν υποθέσουμε ότι όλα ήταν για την έκδοση 3.6.3 (που υποτίθεται ότι αντιμετωπίζει το ζήτημα ασφαλείας), πρέπει να υπάρχουν ακόμα περίπου 500.000 ευάλωτα WordPress sites.

Ωστόσο, οι ερευνητές δεν έχουν επικυρώσει ακόμη την επιδιόρθωση και η ομάδα του Elementor plugin δεν έχει δημοσιεύσει λεπτομέρειες σχετικά με την ενημέρωση κώδικα.

Οι ερευνητές της Plugin Vulnerabilities δημοσίευσαν επίσης ένα proof of concept (PoC) exploit, αυξάνοντας τον κίνδυνο να παραβιαστούν ευάλωτοι ιστότοποι.

Δείτε επίσης: Μήνυση από την Google σε Puppy Scammer που στοχεύει καταναλωτές

Επομένως, οι διαχειριστές πρέπει να εφαρμόσουν άμεσα την πιο πρόσφατη διαθέσιμη ενημέρωση για το Elementor WordPress plugin ή να καταργήσουν εντελώς το plugin από τον ιστότοπό σας.

Οι ερευνητές βρίσκουν συχνά ευπάθειες σε WordPress plugins που συχνά θέτουν σε κίνδυνο μεγάλο αριθμό sites. Μάλιστα, πολλές φορές, οι ευπάθειες αυτές μπορεί να μην διορθώνονται εγκαίρως. Η Patchstack, που ασχολείται με το WordPress (ασφάλεια, απειλές κλπ), κυκλοφόρησε μια έκθεση για να παρουσιάσει την κατάσταση της ασφάλειας του WordPress το 2021. Δυστυχώς, τα ευρήματα δεν είναι αισιόδοξα, αφού αποκαλύφθηκε ότι πολλές ευπάθειες σε WordPress plugins δεν είχαν λάβει διόρθωση. Πιο συγκεκριμένα, το 2021 σημειώθηκε αύξηση 150% στις αναφερόμενες ευπάθειες σε σύγκριση με το προηγούμενο έτος. Το πιο ανησυχητικό, όμως, είναι ότι το 29% των κρίσιμων σφαλμάτων που εντοπίστηκαν σε WordPress plugins, δεν έλαβαν ποτέ ενημέρωση ασφαλείας.

Πηγή: Bleeping Computer

The post Elementor WordPress plugin: Κρίσιμη ευπάθεια επηρεάζει χιλιάδες sites appeared first on SecNews.gr.

https://www.secnews.gr/

%d bloggers like this: