HACKING

Η zero-day ευπάθεια του Windows PsExec αποκτά δωρεάν micropatch

This post was originally published on this site

Ένα δωρεάν micropatch που επιδιορθώνει μια ευπάθεια τοπικής κλιμάκωσης προνομίων (LPE) στο εργαλείο διαχείρισης των Windows PsExec της Microsoft είναι τώρα διαθέσιμο μέσω της πλατφόρμας 0patch.

Το εργαλείο PsExec επιτρέπει στους διαχειριστές συστήματος να εκτελούν προγράμματα σε απομακρυσμένα συστήματα. Το εργαλείο ΡsExec ενσωματώνεται επίσης και χρησιμοποιείται από εταιρικά εργαλεία για την απομακρυσμένη εκκίνηση εκτελέσιμων σε άλλους υπολογιστές.

Αυτό το zero-day του PsExec προκαλείται από μια ευπάθεια named pipe hijacking (επίσης γνωστή ως named pipe squatting) που επιτρέπει στους εισβολείς να εξαπατήσουν το ΡsExec για να ανοίξει ξανά ένα κακόβουλα δημιουργημένο «named pipe» και να του δώσει δικαιώματα τοπικού συστήματος.

Μετά το επιτυχές exploit του σφάλματος, οι απειλητικοί παράγοντες θα μπορούν να εκτελέσουν αυθαίρετες διαδικασίες ως Local System που τους επιτρέπει να αναλάβουν αποτελεσματικά την χρήση του μηχανήματος.

Επηρεάζει τις εκδόσεις PsExec που κυκλοφόρησαν τα τελευταία 14 χρόνια

Ο ερευνητής κακόβουλου λογισμικού David Wells ανακάλυψε την ευπάθεια και το αποκάλυψε δημόσια στις 9 Δεκεμβρίου 2020, 90 ημέρες μετά την ενημέρωση της Microsoft και απέτυχε να διορθώσει το σφάλμα.

Ενώ ερεύνησε την ευπάθεια και δημιούργησε ένα proof-of-concept, ο Wells μπόρεσε να επιβεβαιώσει ότι η zero-day ευπάθεια επηρεάζει πολλές εκδόσεις των Windows από τα Windows XP έως τα Windows 10.

Διαπίστωσε επίσης ότι επηρεάζει πολλές εκδόσεις ΡsExec, ξεκινώντας από την v1.72 που κυκλοφόρησε το 2006 και τελείωσε με την ΡsExec v2.2, την τελευταία έκδοση που κυκλοφόρησε πριν τέσσερα χρόνια, πράγμα που σημαίνει ότι η zero-day ευπάθεια επηρεάζει όλες τις εκδόσεις PsExec που λανσαρίστηκαν τα τελευταία 14 χρόνια.

Το Micropatch ισχύει μόνο για την τελευταία έκδοση του PsExec

Ο Kolsek αναφέρει ότι το δωρεάν micropatch που κυκλοφόρησε σήμερα παραδίδεται στη μνήμη και δεν απαιτεί επανεκκίνηση του συστήματος.

Εφαρμόζεται στην πιο πρόσφατη έκδοση 32-bit και 64-bit ΡsExec, αλλά μπορεί να μεταφερθεί σε παλαιότερες εκδόσεις ΡsExec ανάλογα με τα σχόλια των χρηστών, όπως έγραψε ο Kolsek νωρίτερα σήμερα.

Πηγή πληροφοριών: bleepingcomputer.com

https://www.secnews.gr/security/feed

%d bloggers like this: